Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HELP!

rialb_d

Registered
This is my first post on here. I have a 2004 Hayabusa Limited Edition that is in MINT condition (10k miles) with the exception that my temp or heat gauge is stuck on HOT or MAX at all times. Even with the key out the gauge is still all the way up on HOT. When I put the key in and turn it on, the rest of the gauges ALL sweep to max and back down EXCEPT the heat gauge. The little red light DOES come on in the temp gauge but the needle will not move at all, EVER. LOL. About the only thing I havent tried is unplugging the gauge cluster wire harness plug to see if the needle stays at HOT/max...

I have heard that an air bubble in the coolant system may cause the fan not to come on and other problems, but my fan works (comes on when it gets hot, turns off after a few mins as it cools) and it doesn't seem to run hot or anything. I have also unplugged what I thought was the sensor (at top left of radiator) for the gauge and the needle wont move at all (stays on HOT/max). I am wondering if it is a prob with the mechanical part in the gauge cluster. If it is a prob with the gauge itself, is it possibe to replace only the temp gauge in the cluster? Just wanted a little more info before I remove the nose... AGAIN! LOL. :banghead:

ANY HELP IS VERY MUCH APPRECIATED! THANKS.
here is a video of the gauge stuck.

 

twotonevert

Member of P.E.A.
Moderator
Donating Member
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Welcome to the oRg. I cant answer your question, but someone will be along shortly that can give you some trouble shooting tips. :welcome:
 

rialb_d

Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Thanks. I'm sure I'll figure it out with some help from you guys.
 

Tufbusa

Track Coach / TufPoodle Coach
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Since the needle doesn't move when the key is in the off position, my guess is the issue is in the gauge. I don't think you need to remove the upper fairing to pull the gauge cluster and unplug the wiring harness.

You may want to unplug the gauges, wait 2 minutes and plug them back in to see if the gauge may reset itself. Best way to check for a gauge issue is to have another gauge cluster to plug into the harness.

If the gauge went to the cold position when the key was turned off and back to hot with the key is on, I'd say you had a grounded wire from the sending unit or a bad sending unit itself.
 

SoCal Blur

Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

I agree with Tuf. If all power is removed (i.e., key out or even battery disconnected) and the guage is still doesn't move, the guage is bad and will need to be replaced.

On the plus side, when people look at your bike they will say "Hey, your bike is hot!" :laugh:
 

rialb_d

Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Thanks a lot Tuf, and SoCal! Is it possible to ONLY replace the Heat Gauge and not the whole cluster? If so, is it very difficult? I have more than average know-how knowledge in electronics, just dont know what is or isn't replaceable on the gauge cluster. Thanks again guys!
 

GIXERHP

ok, ok...just a wee bit Irish...
Donating Member
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Try a gauge reset first

gauge reset.jpg
 

GIXERHP

ok, ok...just a wee bit Irish...
Donating Member
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

And if that does not work,, , if it does not move then time for my next page,
follow these instructions,

gauge reset 2.jpg
 

GIXERHP

ok, ok...just a wee bit Irish...
Donating Member
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Finally, if everything tests ok, and it is still stuck, remove the cluster, and open the gauges and try to move the needle. It should not take much effort if it is frozen.
If moves plug the cluster back in and try it again!
 

GIXERHP

ok, ok...just a wee bit Irish...
Donating Member
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Oh also, does your bike have HID's?? If so where is the ballast mounted?

If it is mounted right behide the cluster, that will cause this same problem
 

dadofthree

Seasoned Beef
Donating Member
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Absolutely nothing to add to Johns comments :bowdown:
 

rialb_d

Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Thanks sooo much gixerhp! I didn't have any idea, you could do a reset of the gauge! And yes, I do have HIDs bright and dim, so I will try the reset and then unplug my ballast to see if that corrects it. Thanks again!
 

Tufbusa

Track Coach / TufPoodle Coach
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

John, thanks for that info. I learned something new today that may come in handy down the road.

Thank You! :bowdown:
 

GIXERHP

ok, ok...just a wee bit Irish...
Donating Member
Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

TaDa! :bowdown::bowdown::bowdown::bowdown:

Thanks!
 

JohnnyDangerous

Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Just something to add, when I plugged my new gauge cluster in to make sure i had all the right connections and starter etc the temp gauge went to full on hot as soon as the ign was switched on, at this time I had no flasher/sidestand relay in place, as soon as I plugged one in the temp was perfect.
 

V8Pinto

Registered
Re: Temp gauge stuck on HOT/max all the time even when key out & wont sweep PLEASE HE

Do you mean turn signal flasher?
 

Latest Bikes

Forum statistics

Threads
178,149
Messages
3,210,631
Members
50,624
Latest member
Goblin03
Top