Blocked radiator





Mr.Nix

Registered
Well a friend if mine brought his gen 2 with 14k by said he had a leak in either a hose or the radiator, so we pulled the panels on it and could see white marks on the radiator like the hose might have been leaking! So I pulled the hoses and found both ends just about blocked up, don't know what would cause this as he never had the bike over heat?? Thx for any advise

image-110643220.jpg


image-488105943.jpg


image-3889904635.jpg
 

GIXERHP

ok, ok...just a wee bit Irish...
Donating Member
Registered
I have never seen thiss, what was the temp at?
 

Hayabusawannabe

Registered
I dunno but I've read on another site that Hayabusa's typically have sludgy build up in the coolant system. I forget why and what the name of the site was. I think mine has it too but it doesn't over heat.
 

icemansid

Donating Member
Registered
take to your local radiator shop and have them boil it out - will clean it out and make like new.
 

Mr.Nix

Registered
Well took it to the radiator shop said it was totally blocked up and they couldn't fix it, they do repair aluminum radiators also just this one builds pressure and just breaks again :-(. Yes he is the original owner but ha a guy that worked on it a few times so we don't know what got put in there ?
 

isiahstites

Registered
Well took it to the radiator shop said it was totally blocked up and they couldn't fix it, they do repair aluminum radiators also just this one builds pressure and just breaks again :-(. Yes he is the original owner but ha a guy that worked on it a few times so we don't know what got put in there ?
If the radiator is blocked like that most likely all of the water passages in the engine are as well. No bueno!
 



Latest Bikes

Forum statistics

Threads
172,219
Messages
3,079,611
Members
47,407
Latest member
Wilbert bush
Top