Front brakes squeak a little




Bosch232

Registered
Hey all,

Glad to see all is back.

I've got a 2002 Busa with 1,450 miles on it.  In the last 50 miles or so, the front brakes like to squeak some when I apply them. It's not obnoxiously bad, but is definately there.

I do not ride hard, nor do I ride very often.  Possibly a bit of surface rust has developed on the rotors?  I don't see any there, but maybe there's something that's hard to detect. Could there be a buildup of aesbestos dust on them, or something? Just thinking out loud here.

Has anyone else experienced this?  I'm not overy worried about it, but it's a bit annoying.

Thanks.

Bosch
 

cache

Banned
My '02 didn't even have 200 miles on it before the front brakes started squeaking. Weather is the biggest player there, but I made the dealer give me new pads under warranty. Good pads too. Haven't had a problem since.

Pretty embarrasing cruisin through town on a nice new bike and have a huge annoying squeak in the front!
hmmm.gif
 

Big O

Physicist Genii
Donating Member
Registered
Might be dirt on the pads or a film of something on the rotors. Maybe try washing the rotors.
 

SMOKEDBUSA

Registered
NEVER HAD THE PROBLEM WITH STOCK PADS, CHANGED TO DUNLOP RACE ONLY PADS AND THEY WERE NOISY AT FIRST, BUT NOW THE MAY GIVE A LITTLE SQUEEL ONCE AND A WHILE, BUT WHAT A DIFFERENCE IN STOPPING POWER!
 



Latest Bikes

  • Hayabusa Addict
    From back to front; 2014 9.99 index champion 2005 all motor class...
    • Motonutz916
    • Updated:
  • My Gen 3 Busa
    Photos of my 10 year freshen up on my 2009 Hayabusa. Parts highlights...
    • fallenarch
    • Updated:
  • Art 05 Hayabusa
    hayabusa 05
    • VIPER
    • Updated:
  • toads L2
    L2 as it is ridden today
    • ROADTOAD1340
    • Updated:
  • Busa in another part of Cornwall
    Cotehele pretty spot but residents didn't appreciate the Busa. I guess...
    • Grumpyoldjohn
    • Updated:

Forum statistics

Threads
172,592
Messages
3,086,663
Members
47,566
Latest member
Tim B
Top