Fi light stays on

gaetano

Registered
I was riding yesterday and my FI light stayed on and my clock alternates between the time and FI. Has anyone ever had this happen to them? I looked in the manual and it says that there is a minor problem with the fuel injection system? I brought it to the dealer and they are going to look at it next week but if anyone can ease my mind if they have had this happen to them and know what might be the cause, I'd appreciate it. Thanks
 

Curt

Registered
I was riding yesterday and my FI light stayed on and my clock alternates between the time and FI. Has anyone ever had this happen to them? I looked in the manual and it says that there is a minor problem with the fuel injection system? I brought it to the dealer and they are going to look at it next week but if anyone can ease my mind if they have had this happen to them and know what might be the cause, I'd appreciate it. Thanks[/QUOTE]<span id='postcolor'>
happened to me quite a few times. i posted about it before. not sure what caused it, i normally just hit the kill switch, wait til it goes off, start it up again. prolly not the best solution, but that's me
tounge.gif

i took the bike dragracing again last weekend, and ran the same times, so i guess everythings working how it should. ima get it checked out if it persists.
for the record, its happened to me about 10 times, most during a one week stretch, and the last time was 2 weeks ago, and it hadn't happened for a while before that.
i'm starting to think it myt have something to do with when i hit a bump, cuz 3 or 4 times were while i crossed a set of tracks before my house and it rocks the bike pretty good.
 

Narcissus

Hayabusa Immortal
Moderator
Registered
Remove the rear seat/hump and look on the left side for a covered connector. It should have two wires going to a 4-pin connector. With the ignition on and kill switch off (run position), jump the two wires on this connector. Look at the dash at the top display. It will reveal a code or codes listed sequentially. If you already have a manual, look in chapter 4 for the codes (the manual is available here, although I think it is currently not working). In the mean time, post any codes and I will translate.

BTW, C00 is the 'normal' code (no errors). This needs to be done when you get an FI light. All codes will be reset when you turn the ignition to the 'off' position and you will only see them again if a sensor has already failed or until the conditions for the previous failure are met again.
 

Curt

Registered
cool, i was wondering what that lil connector was for
what do i use to connect the pins?
and will i still get a code from when this happened before, like, is it stored in memory or something?, or do i have to wait til it happens again. cuz it hasn't happened in the past 3 weeks.
 

abusaboy

Registered
yeah had same problem but lite only comes on at 7000rpm in any gear, the dealer checked it on the clock readout and it said error: co1, co2, co3, co4, which apparently means ignition fault of somekind !!!! a job for Suzuki GB.....
 

Headhunter

Registered
Right after I bought my 2002 Busa, I had 8 miles on the taco and got the FI light, come to find out, the fuel injection wiring harhess was bad on the number 4 injector.
 

microdisk

Registered
I am having a similar issue, but my 01 one day just didnt want to start.. After I took a few things apart, I found that there is no spark. I crossed the wires as mentioned above and found error's C13 and C21.. Can anyone tell me what this means please??
 

microdisk

Registered
Sorry, please disregard the above query ..

Accidentally, I found out that C13 and C21 relate to the Air Filter Box been taken off..

Funnily enough, once I attached the air filter, I got a C00 (All OK) Code, and when I tried to start it, it fired first time! (Go Figure!)
 

Latest Bikes

Forum statistics

Threads
178,174
Messages
3,211,328
Members
50,635
Latest member
Busawizard1
Top