Blowing Fuses


snbusa

Registered
#1
Blew first on left above spare 10: No lights/gauges cept head and hi beams, bike ran fine; turned key all way to left (lights0 and heard pop, now its completely dead won't run. I'll check back in a while and see if anyone has light to shed;;;; Pun intended. Thanks.
 

IG.

Registered
#3
Holy crap, Nic! Seems like the main fuse got busted. If I knew you'd try turning the key to the left, I'd say NO because turning the key to the left lights up all signals, and we know that there is a short somewhere in the signal circuitry. I am guessing that because the ignition wasn't ON, the only fuse deployed in such key position would be the main fuse, and that's why it blew. I'd say the tail needs to come off, as well as the left fairing, and the tank needs to be propped up. Then tracing wires, unplugging the rear end, and looking for pinched/exposed wires/connectors in the tail section.
 

snbusa

Registered
#4
I lifted White Lightening by her tail and heard the tail fairings creak but not break. I also took the hump off and put the back around bar on her. Ig and I uncoupled the two wire connections in front of the tail light and the problem persisted. We ran out of time due to night fall and I'm planning on trouble shooting tomorrow with my brother and pulling the tail fairing off if necessary. Ig will be available by phone as he is knowledgeable.
 

snbusa

Registered
#5
It was an accident! I just turned it too far by accident because I got the key working so well with the graphite. Thanks so much for all your help today and setting me up for a fix tomorrow. U da best IG!
 

rubbersidedown

BUSA-RIDIN'-BASTID
Donating Member
Registered
#6
I lifted White Lightening by her tail and heard the tail fairings creak but not break. I also took the hump off and put the back around bar on her. Ig and I uncoupled the two wire connections in front of the tail light and the problem persisted. We ran out of time due to night fall and I'm planning on trouble shooting tomorrow with my brother and pulling the tail fairing off if necessary. Ig will be available by phone as he is knowledgeable.
Perhaps when you installed the "back around bar"...(its called a grab bar bro,) you pinched one of the wires and now have a short.Or could have happened when you picked her up by the tail.

maybe remove those 4 bolts and look for a crushed wire.

I dont know shi7,just a guess.

Good luck with it.

Rubb.
 

Busa1166

Donating Member
Registered
#7
I also vote for a grounded wire in the running lights/turnsignal. check your bulbs also a bad bulb could cause a short also if the filament is broken and touching the metal on the inside. Doesn't happen to LED bulbs though:whistle:
 

snbusa

Registered
#9
Manny gets the prize! Also Rubb on track. IG! Once again PQWERHOUSE strikes again; Loads of props FRANK and last bu not least a great day for RRakovic Racing as I found it myself. Thanks to all. Nic
 

Most likes - Past 7 days

Forum statistics

Threads
170,620
Messages
3,066,783
Members
46,792
Latest member
maroonbusa
Top