Power Commander V Ignition Module Issue





#1
Hey guys, Im new to the fourm. Im having a problem with my Ignition Module to my PCV. I'm building a turbo Busa powered sand drag quad and I got it all fired up. But as soon as I added the Ignition module to the power commander network I got a red light flashing on the module its self and my power commander software wont load or send a map to ether the IM or PCV. The ignition module has error code 304, once I remove the Ignition module from the PCV network the PCV behaves normally and every thing functions correctly. Ive double checked my installation several times, all coils and crank position connected correctly. Ive tried reinstalling firmware, and re syncing devices in the PCV software. Ive tried connecting to the IM through the PCV with key on power, tried connecting directly to the IM through USB and tried connecting to both PCV and IM through separate USB. I have the red blinking light at all times, when plugged in via usb, when key is on, when engine is running. Any idea what going on here?
20190307_184026.jpg
 
#2
Badass quad. Did you read the instructions? When adding the ignition module to the pc5 you have to go into the pc5 and make some changes so it sees the ignition module. It's all in the instructions but ypu can find it on YouTube or email power commander.
 

Similar threads





Most likes - Past 7 days

Latest Bikes

Forum statistics

Threads
171,399
Messages
3,059,402
Members
47,105
Latest member
Almanzar23
Top