Need help..





#1
Changed my front sprocket yesterday to a 17 on genII. Everything went fine, rode last night with no issues. Started the bike this morning and I have no Tach or MPH everything else works fine. Checked all fuses and rechecked the speed sensor connection... evrything is fine. Checked the speed sensor with a Ohm meter and two of the prongs have resistance (3 wires). I unplugged the sensor and started the bike and nothing extra changed. Tried unhooking battery and still the same. Has anyone unplugged the sensor and started the bike? Wondering if they will get the same "no tach and Mph". Thanks, Dozer.
 

Commuta_Busa

Donating Member
Registered
#2
Did you disconnect anything when you swapped sprockets?
Sounds unrelated to swapping the front sprocket. Do you have an alarm system? What extra "stuff" do you have wired into the bike?
 

Commuta_Busa

Donating Member
Registered
#4
As much as a pain it may be I would pull the nose and see if everything looks ok. It's odd that only the two gauges don't function. It sounds like a short in the wirring some where.
 
#5
I am leaning towards the speed sensor... the tach and speedometer cycle when it's going through the check sequence. I am going to get my friend to unplug his speed sensor to see if it will simulate the same problem as mine. Will update soon.
 

Commuta_Busa

Donating Member
Registered
#7
when you mentioned you started the bike and no tach or speedo I thought you meant it never cycled on start.

Look for the star on the front sprocket since you already checked the actual sensor. You may want to also check the connections at the ECU.

What electronice do you have on your bike? PC/Bazzaz? Alram? Ign. box? How were they wired up? Perhaps there's a break in the OE wiring some where....
 

Similar threads




Top