Big O

Physicist Genii
Donating Member
When I put the choke on, it doesn't raise the idle speed.  Even when it's cold.  I lifted the tank and looked at the cam and it doesn't even touch the throttle when it's on even after I adjusted it as much as I could.  How do I fix this?
How old is your bike. WARRANTY Sounds like the cable may be breaking strands.
Technically, it's a 'throttle advance' not a choke, being FI and all. If the cable moves when you move the lever on the bar, change the adjustment at the throttle body. If it doesn't, suspect a broken cable and replace.
the finger that hits the stop screw on mine is bent back at
a 45 deg. when I straightened it the "choke" would not rasie
the idle, so I bent it back to 45 deg. now it works.
It's a '02 and still under warranty, the cable moves the throttle advance cam (thanks Narc, I couldn't remember, I was tired). I'll use your suggestions and get back to you on this.
Thanks guys.
I took Hangman's advice and bent the throttle advance stop tab back 45 degrees and the idle went up to 2k. Ok so maybe it's not a by the book fix but it worked. I was at my mechanic's shop and he showed my two heads from 'Busas and neither one of the throttle advancers worked.

Thanks for the suggestions guys!