How do you replace the fuel filter

Discussion in 'Maintenance and Do-It-Yourself' started by Hawk, Sep 2, 2009.

  1. Hawk

    Hawk Registered

    Messages:
    12
    I'm having some issues getting the busa started. '05 with 30k miles. It had been running and strating great up untill a month ago. Everything was running well and then I noticed as I would reach higher rpms it would begin to stutter. It use to start with out fail with one crank, but then it stated taking two. Now I have to roll on the throtle when I hit the starter and that gets her to fire up. I changed the plugs and that didn't really help. I ran fuel system cleaner, twice, and that didn't help. Now I'm just working down the list. Anyone have pictures (visual learner) of where it is and how to get to it?
     
  2. BA BUSA

    BA BUSA MotoGP Wannabe Donating Member

    Messages:
    12,734
    Location:
    Santa Clara, California
    When was the last time you changed your spark plugs ??? :whistle:
     
  3. turbobusa2000

    turbobusa2000 Registered

    Messages:
    1,905
    Location:
    Wisconsin
    He said he already did.::25
     
  4. BA BUSA

    BA BUSA MotoGP Wannabe Donating Member

    Messages:
    12,734
    Location:
    Santa Clara, California
    My bad :banghead:
     
  5. twotonevert

    twotonevert Member of P.E.A. Moderator Donating Member

    Messages:
    26,314
    Location:
    Tehachapi CA
  6. Hawk

    Hawk Registered

    Messages:
    12
    I read through the manual first and it didn't really help. I also searched on here to see if the question had been asked, but no one had, directly at least. My symptom could have another cause, but I think it's at least worth checking.
     
  7. mike1180

    mike1180 Banned

    Messages:
    5,705
    Location:
    Alberta, Canada
  8. Hawk

    Hawk Registered

    Messages:
    12
    :thumbsup:Thanks
     
  9. mike1180

    mike1180 Banned

    Messages:
    5,705
    Location:
    Alberta, Canada
    :thumbsup:
    Anytime brother.
     

Share This Page