Where does this washer go to?





euroR

Registered
#1
I had my bike painted and the guy who painted it gave me one of these washers. I looked all over the parts catalog to see where it fits but no luck. Anyone here can tell me have you seen this on your bike.

20150128_142753.jpg


20150128_142806.jpg
 
#3
I had my bike painted and the guy who painted it gave me one of these washers.
But did he tell you if it came off your bike?
If he just found it on the floor under your bike that doesn't mean it's from your bike.

Never seen that in/on a Busa, and will be surprised if it is from a Busa.

Does your bike run fine - no problems and or noises, shakes, rattles etc?

Do you have (both) spools on your bike?
 
#5
Picture didn't look like rubber. At least like black rubber which is what mine are.

Yes there are 2 of those on each side fairing.
I believe 2 on the rear tail faring.
None in the nose fairing.
I think 2 in the under belly wing by the exhaust pipes.

That's all I can think of right now. Above is for a Gen I.
 

euroR

Registered
#6
But did he tell you if it came off your bike?
If he just found it on the floor under your bike that doesn't mean it's from your bike.

Never seen that in/on a Busa, and will be surprised if it is from a Busa.

Does your bike run fine - no problems and or noises, shakes, rattles etc?

Do you have (both) spools on your bike?
He only had the plastics. I kept the bike. Im going to go to a suzuki dealer tomorrow to see if i can see anything.
 

Got-Busa?

Donating Member
Registered
#8
Hard to tell from the pics but looks like the rubber washer on the tail section when you look down with the hump off. Philips head screw goes in that location...

FRAME COVER

#19 but hard to tell!
 

euroR

Registered
#9
Hard to tell from the pics but looks like the rubber washer on the tail section when you look down with the hump off. Philips head screw goes in that location...

FRAME COVER

#19 but hard to tell!
I thought that too but all of those are in place. I think he lost one so he found a similar one thinking thats it.
 
#11
I thought that too but all of those are in place. I think he lost one so he found a similar one thinking thats it.
So you are not missing any?

On my Gen I there are 8 total - that look like what you first posted.

Did you remount all the plastics? All is good? Maybe you have an extra now.
Let us know if/when you figure it out.
 

Similar threads




Top