turn signals not working





BUSA SS

Donating Member
Registered
#1
Got the clear alternatives tail light set up with the flasher unit.Installed it thursday and it worked fine.Went riding with a friend friday and when I would signal it would stay lit.Then they stoped working all together(front and rear).Everything is still hooked up like it was to begin with.Tail and brake light work fine.Any help would be greatly appreciated
 

MC MUSTANG

Peace Keeper or Ban Hammer-it's up to you; IDMBT#9
Staff member
Administrator
Registered
#2
Can you take pics of your set up? Also, check and make sure that there are no breaks in your wiring and that the fuse is good under the left side inner fairing.
 

BUSA SS

Donating Member
Registered
#3
Forgot to add that we that we stoped and checked the fuse and it was good.I'll swap another one in right now just to make sure
 

heavybusa

Just another guy
Donating Member
Registered
#4
+1, you have to rule out a loose bulb or wire and/or fuse before you start taking stuff apart.

Do you have a test light?

tlight-1.jpg
 

BUSA SS

Donating Member
Registered
#5
No blown fuses.Can't get any pics(cams broke).I got a test light just have to track it down.Thanks for the fast response guys.
 

MC MUSTANG

Peace Keeper or Ban Hammer-it's up to you; IDMBT#9
Staff member
Administrator
Registered
#6
When you say flasher unit, do you mean an integrator or do you mean a flasher relay? Also, did you use inline resistors? If so, check those and make sure they are still wired tight.
 

BUSA SS

Donating Member
Registered
#7
I'm assuming it is a relay.I had to pull two wires out of the the stock flasher and plug them into the new one that they sent me.It says that I will now have two flasher units.Did not use the relays.
 

BUSA SS

Donating Member
Registered
#8
Found the problem!The flasher that I got from them is junk.Put the wires back into the stock flasher and turn signals work now.Thanks again guys
 

MC MUSTANG

Peace Keeper or Ban Hammer-it's up to you; IDMBT#9
Staff member
Administrator
Registered
#10
Got your message, that was why I gave you my number... I was gonna have you do that and see it if fixed the problem...

Oh, and Welcome!
 

BUSA SS

Donating Member
Registered
#11
I have to say,I belong to two other fourms(4wd.com and ImpalaSSfourm.com)and never have I got such a fast response from them as I did here.Usually it would take two days if at all.I'm glad I found this fourm.You guys are awsome.Thanks again

Sam
 

MC MUSTANG

Peace Keeper or Ban Hammer-it's up to you; IDMBT#9
Staff member
Administrator
Registered
#12
(BUSA SS @ Sep. 09 2006,15:31) I have to say,I belong to two other fourms(4wd.com and ImpalaSSfourm.com)and never have I got such a fast response from them as I did here.Usually it would take two days if at all.I'm glad I found this fourm.You guys are awsome.Thanks again

Sam
That is because you had a relatively easy problem. Now if you needed to know what a TRE is, or which side of the bike was which, you'd be waiting for awhile, cause none of us know!
 

Similar threads




Most likes - Past 7 days

Forum statistics

Threads
170,982
Messages
3,078,457
Members
46,928
Latest member
Stevil
Top