Turn signal help...

papi_ocho

Registered
My right turn signal is not working..

But what it is doing it turning the indicator light on. It stays on steady. No flashing.

Everything is wired correctly. The left turn signal works just fine.

My 4 ways technically work how they should if the front right light would light up when activated.

When activating the right side. I get nothing. Along with my dash light being on. The rear signal stays on too.

Sometimes while riding the dash light will go out. And they work normal once or twice. Then it's back to staying on steady.

Any ideas? Anyone?

I'm ready to quit. :mad:
 

kromdom

wannabe HOON
Donating Member
Registered
was a filament burned out in the bulb on the right? hope it stays fixed for good :)
 

Lucid

Registered
Sounds like it's just a dang bulb.

Sometimes while riding the dash light will go out. And they work normal once or twice. Then it's back to staying on steady.

I have no idea what this means btw but it sounds like a problem. Background dash light? I don't understand "they work normal once or twice". When the flasher is on? Once or twice a week?
 

papi_ocho

Registered
Sounds like it's just a dang bulb.



I have no idea what this means btw but it sounds like a problem. Background dash light? I don't understand "they work normal once or twice". When the flasher is on? Once or twice a week?

Let me try again.

When operating normally. The dash mounted signal indicator flashes on off on off repeat.

Mine would stay on all the time. Weather the signal was activated or not.

Sometimes it would "fix" its self and operate normal, but only for a few minuets.

Rode about 100 miles mixed city/highway today. And they are operating like they should be.
 

Latest Bikes

Forum statistics

Threads
178,442
Messages
3,217,401
Members
50,722
Latest member
Noby John
Top