Running 08 with no O2 sensor?

ZeePopo

Registered
In the process of removing my stock exhaust and installing a R77 system the oxygen sensor seared off while being removed. Seems like the housing that holds the element in welded itself to the exhaust. Either way now I need a new O2 sensor but I seen some guys running without the sensor and using a dummy plug. Is that an option without a PC or Bazza? What should I do?
 

ChinoCIA

Registered
From my understanding the o2 sensor is mainly for emissions control. It ensures that at cruising speeds your bike will run "lean" which in result controls your bikes emissions output. I wouldnt recommend prolonged mileage without an o2 sensor. Might shorten the life of your engine. That just my educated opinion though. Im not a certified mechaninc.
 

Dennis

Registered
I don't understand what was damaged, but yes, if you are able to put the dummy plug in the harness in place of the 02 sensor that will work fine. If you know somebody who can flash the ECU you can turn it off in there too. You'll need to plug the hole in the new exhaust with something, either buy the proper bung and plug or get an old 02 sensor to screw in.
 

ChinoCIA

Registered
I don't understand what was damaged, but yes, if you are able to put the dummy plug in the harness in place of the 02 sensor that will work fine. If you know somebody who can flash the ECU you can turn it off in there too. You'll need to plug the hole in the new exhaust with something, either buy the proper bung and plug or get an old 02 sensor to screw in.

What he said ^^^^^^
 

Ludicrous Speed

Registered
For some reason, my very expensive exhaust did not come with a bung for the O2! I unplugged it, and switched it off in ECU editor. Never had an issue since.
 

ZeePopo

Registered
I don't have ECU editor ::whistle:. If the ecu sense a error with the O2 sensor will it then run richer in a loop?
 

ZeePopo

Registered
Just called Yosh. They said no problem, I can run it without the sensor. In a week or two Ill just get a Bazzaz with the wideband O2. No point wasting money on a stock o2 sensor. They wanted 200 bucks for one here :moon:
 

Got-Busa?

Donating Member
Registered
Just called Yosh. They said no problem, I can run it without the sensor. In a week or two Ill just get a Bazzaz with the wideband O2. No point wasting money on a stock o2 sensor. They wanted 200 bucks for one here :moon:

Make sure the exhaust you have/buy fits the correct O2. The narrow band sensor that comes OEM is a different size than wideband sensors on most loggers. I can't remember off the top of my head but the Bazzaz setup is the larger size if I remember right. Double check to make sure.

Also, you can buy those sensors for $40-50 if you shop around, and the dummy plug is $15-20.
 

Mythos

Registered
dummy plug here for last year and no problems. No ECU flash, just a Bazzaz loaded with map for my setup.
 

Latest Bikes

Forum statistics

Threads
178,135
Messages
3,210,323
Members
50,615
Latest member
BlackHawk1
Top