Problem...need help clutch





TapRackNGo

Registered
OK,

So I put a new 16T sprocket on while the cover was off I knocked the rod loose and clutch fluid came out. Placed everything back together, and clutch has no pressure. I tried to bleed it, fluid comes out but still no pressure in the clutch. I took everything apart and put the rod, spring, back in and it was full of fluid which dumped out. Again I tried to bleed, which I got fluid to come out, but still no resistance with the lever.

Any Ideas?

Need help asap as I am riding tomorrow.

thanks guys
 

Charlesbusa

Used to be a SoCal Busa
Donating Member
Registered
I've heard that it takes a really long time to bleed the clutch, unless you have that suction vacumm device. If you're bleeding without a suction, it will probably take a long time.

Keep at it.
 

300Busa

Chillaxin...
Donating Member
Registered
Just make sure you keep it full of fluid when bleeding it. Don't want to almost be done and then suck more air in.
 

TapRackNGo

Registered
it doesnt seem to be sucking anything. I took it apart again and filled fluid behind the piston, and checked for movement. It does move but only slightly. When pumping it still has no resistance. Damn Im stumped....:(
 

BusaCruise

speachless
Donating Member
Registered
if it's the stock clutch line....they're a PITA.

so many little bends and such for air to get trapped in.... change to a braided line next chance you get.

good luck



<!--EDIT|BusaCruise
Reason for Edit: None given...|1156596089 -->
 

Shanling

Man ***** Extreme
Donating Member
Registered
I have a question about the clutch too. Mine is almost all the way out when it engages. Is that normal?
 




Latest Bikes

Forum statistics

Threads
172,054
Messages
3,075,754
Members
47,333
Latest member
Markthomas912
Top