Oh, the crankcase vent...




Narcissus

Hayabusa Immortal
Moderator
Registered
Why didn't I think of checking this before? You know, of all the things I've been checking, you'd think I would take a few seconds to check if it was clogged. :banghead:


Anyway, removed the oil trap and it was filled up with oil and sludge. This would completely explain why it would run fine, then start hesitating/stalling, then run fine again. I'm sure it isn't the only problem I've been having and fixing, but a major one nonetheless.


Anyone clean one of these out? It's the black bladder-looking thing connected to the middle-back of the airbox. Not sure if I should run solvent through it or just use compressed air to blow all the crap out. ???
 

brad

Registered
Good call Paul, I've never checked mine. Stands to reason that it can/may clog up. Going to check it today. Thanks.
 

Narcissus

Hayabusa Immortal
Moderator
Registered
I don't think I've really cleaned it out in the past ten years.

Of course, it also means I have some blow-by through the rings. I might eventually be forced to do a big bore-kit, and then have no choice but to install a turbo. This deeply saddens me. :(
 

S-R Racing

Registered
I don't think I've really cleaned it out in the past ten years.

Of course, it also means I have some blow-by through the rings. I might eventually be forced to do a big bore-kit, and then have no choice but to install a turbo. This deeply saddens me. :(
Ooohhh... the pain!...do it now....end the suffering. You must put an end to the hurt....you know what you must do for the greater good-think of what your Busa has done for you. Oh the hummanity...make it right:please:
 



Latest Bikes

Forum statistics

Threads
172,731
Messages
3,089,481
Members
47,629
Latest member
Weston Goldberg
Top