New owner need some help please!!!




RedBull

Registered
OK~
It happened again
and I was ready .

Laugh out loud .

c23 tip over sensor .









:lol:

#c23 ~ #DealerCode ~ #ForTipOverSensor ~ #THEoRg *

 

Kidn1980

Registered
ok well went and took for a ride other then in neighborhood and didn’t shut done nor got the code so good in that part.........

NOW as I was riding it started to overheat on me so I’m assuming the fan didn’t turn on but then heard fan turn on after it shut off. So I assume the tstat was not opening or maybe stuck. Turned off for a bit on side of road and turned back on and temp was in middle the rest of ride assuming tstat was stuck and then gave...still going to look at fuses and fan tomorrow.

ANOTHER issue is it rides up to 45mph and then I tried to speed up and it bogged/hesitated, dropped power like it was starving for fuel and then BOOM picked up like the fuel kicked in. It did that multiple times so I assume injectors need to be cleaned since it sat since 2013 and I haven’t cleaned them yet. Can one of y’all tell me or post a video for me to look at on how to clean then please. Again thank y’all for the help in advance.

I’m learning as I go and I WILL GET THIS BABY TO PAR
 

Kidn1980

Registered

#c23 ~ #DealerCode ~ #ForTipOverSensor ~ #THEoRg *


Thank you sir
 

Kidn1980

Registered
Ok so i didn’t burp and took it out and didn’t over heat till I got home and let it sit while running temp raised up and fan didn’t kick on. Turned bike off and turned key in on position and fan turned on. Turn key back off and back on and the fan didn’t turn back on.

I tried to video the bike what it’s doing when I start to get up in speed and when reach 5k rpm it starts to cut out and sputter and good and then bad, hard to explain but won’t let me post video.
 

Kidn1980

Registered
i did, well I looked at it and it doesn’t move and it go all the way in and out.

I was watching this video and makes me think. When I took the tank off to dump old fuel out there was A LOT of rust and did my best to clean it out. I believe my pump is in my tank or am I wrong.

 

Sandow

Registered
i did, well I looked at it and it doesn’t move and it go all the way in and out.

I was watching this video and makes me think. When I took the tank off to dump old fuel out there was A LOT of rust and did my best to clean it out. I believe my pump is in my tank or am I wrong.

It is.. I thought from the beginning that your pump is clogged up based on the rust. Take the tank off, take the pump off and take it apart. Iam sure its full of particles. Make some photos and post them!
 

Sandow

Registered
Can you remove fuel pump and break it down and clean it?

search function here and google is your best friend for questions like this!

Also since you plan on doing all this stuff by yourself- you should definitely get a copy of the garage/owner manual. Everything you need is in there with over 700 pages! If you have whatsapp- shoot me your number and I will send you a copy!
 

Dustin02

Registered
I think this will help out a lot.

 

Kidn1980

Registered
I plan on taking out fuel pump and cleaning gas tank with some rust remover this weekend. Any good videos on how to take apart fuel pump and clean
 

Kidn1980

Registered

search function here and google is your best friend for questions like this!

Also since you plan on doing all this stuff by yourself- you should definitely get a copy of the garage/owner manual. Everything you need is in there with over 700 pages! If you have whatsapp- shoot me your number and I will send you a copy!
Thank you very much
 



Latest Bikes

  • Hayabusa Addict
    From back to front; 2014 9.99 index champion 2005 all motor class...
    • Motonutz916
    • Updated:
  • My Gen 3 Busa
    Photos of my 10 year freshen up on my 2009 Hayabusa. Parts highlights...
    • fallenarch
    • Updated:
  • Art 05 Hayabusa
    hayabusa 05
    • VIPER
    • Updated:
  • toads L2
    L2 as it is ridden today
    • ROADTOAD1340
    • Updated:
  • Busa in another part of Cornwall
    Cotehele pretty spot but residents didn't appreciate the Busa. I guess...
    • Grumpyoldjohn
    • Updated:

Forum statistics

Threads
172,570
Messages
3,086,230
Members
47,558
Latest member
DjDaxBoogie
Top