New busa broke down


#1
I got my Busa this morning, got it out of the crate at Yellow Freight, and got everything ready to go. Had to put the mirrors and the Cluch and brake levers on. Well it ran fine for about 1/2 mile, then the cluch started slipping. Within 2 miles it completely stoped, because it was slipping so bad. So I had to call the local Suzuki Dealer and he came and picked me up. Bike is now sitting in there service department, I should know something more in a couple hours or so.
 
#2
Doggone it, sorry to hear about your problem on the first ride, and after such a long wait. Keep us informed on how things go with it. We hope it is something simple.
 
#3
Thank God, It was something simple. The cluch line just needed to be bled. It is running great now, havnt tached it above 4500 though. Great bike, good and stable. Cant wait till the weekend when I can put some miles on it.
 

Narcissus

Hayabusa Immortal
Moderator
Registered
#5
Clutch fluid was probably dirty. Cover the clutch slave cylinder and change the seal to keep it from going bad again. Metal ducting tape works and some also make aluminum plates to keep it free from the dirt, grease and water that gets spun from the chain.
 

Narcissus

Hayabusa Immortal
Moderator
Registered
#6
BTW, not sure if your bike is new or used. Either way, cover the cylinder. It's another common quality issue on these bikes.
 

Most likes - Past 7 days

Forum statistics

Threads
170,861
Messages
3,073,462
Members
46,894
Latest member
Muracami
Top