My bike is healed, thanks SAE Outlaw Perf

dk55belair

Registered
I posted some threads about my bike cutting out around 6k rpms after I filled up.

I determined after changing a few things, that I got some rusty bad gas in Ga. The reservior and strainer were packed in rust. The inside of my tank looked like new, so it was the gas. I borrowed Telesmiths tank and the bike ran well.

So the alternative to $660 fuel pump from Suzuki was having Mike at Sae Outlaw Performance install a Walbro in my assy. It cost me $238 shipped to my door. They are a sponsor here and I couldn't have asked for better, faster service.

The Walbro is a little noisier, but it doesnt bother me.

I polished my frame and put the bike together and ready to ride some tomorrow.

Thanks Motorman Mike.

IMG_0416.jpg


IMG_0483.jpg
 

BusaWhipped

Donating Member
Registered
Glad you're back up and running. If you keeps your eyes open, you can puck the pump assemblies up on ebay for $50.
 

dadofthree

Seasoned Beef
Donating Member
Registered
Might have missed something here, but is there any chance you could have cleaned the filter and pump assembly and been back in business ?
 

mestona

Registered
Might have missed something here, but is there any chance you could have cleaned the filter and pump assembly and been back in business ?

If the pump is blocked long enough the mechanical resistance increases the current flow through the winding and can damage the winding causing a loss in pump performance.
 

Latest Bikes

Forum statistics

Threads
178,148
Messages
3,210,624
Members
50,623
Latest member
Netrograd
Top