Instrument panel went off while riding.




Ampz

Registered
Lights still on, high beam works and the high beam notification on panel works. Speedo, rpm, gas, turn signals don't. Bike starts up and runs completely fine. Drove all yesterday like that. What is the issue? Fuse?
 

stangman327

Registered
I had this same problem until I noticed I had a half cut wire in my tail section that was making contact with the frame.
 

Ampz

Registered
Definitely didn't see any cut wires. Battery terminals tight. I'm confused. Are there fuses?
 

twotonevert

Member of P.E.A.
Moderator
Donating Member
Registered
Your plug on the back of the cluster is loose, have seen that happen a few times. Turn signals won't work either if I remember correctly.
 

daviesmi

Registered
I had this happen last year on my way to Sturgis. I disconnected the battery, kinda a hard reset no problem sence. Good luck
 

busabass

Registered
Had the same symptoms myself after an HID mod...there is a little 10amp fuse under the left panel. Would also check the cluster connection first. See the manual for location or just pull an check them all while your under the hood...

Sent using Forum Runner
 

captain

Dis in my way!
Staff member
My Gen II did the same thing twice, once was the gauge cluster connector came loose and the other was when the factory harness had a recall and was causing problems...
 

Ampz

Registered
Can anybody show me where the plug is that may have come loose? I reset the battery terminals to make sure things were seated properly and it wasn't that.
 

GsxrBots

Motorboatin' Moonpies, Gangnam Style
Registered
Remove the gauge cluster, there is a huge plug in the back of it that is most likely not fully connected.
 



Latest Bikes

  • Hayabusa Addict
    From back to front; 2014 9.99 index champion 2005 all motor class...
    • Motonutz916
    • Updated:
  • My Gen 3 Busa
    Photos of my 10 year freshen up on my 2009 Hayabusa. Parts highlights...
    • fallenarch
    • Updated:
  • Art 05 Hayabusa
    hayabusa 05
    • VIPER
    • Updated:
  • toads L2
    L2 as it is ridden today
    • ROADTOAD1340
    • Updated:
  • Busa in another part of Cornwall
    Cotehele pretty spot but residents didn't appreciate the Busa. I guess...
    • Grumpyoldjohn
    • Updated:

Forum statistics

Threads
172,578
Messages
3,086,355
Members
47,561
Latest member
Rogdoger45
Top