Gen 2 clutch noise - doesn’t seem normal





MattyIce 79

Registered
Hello .org friends,

My gen 2 is making a noise the doesn’t seem right.

When I’m at a stop proceeding to take off, I begin to let out clutch and feel the clutch engage with a low volume knock ( like a “click”). BUT, if I let it out really smooth with a little more throttle, no knock noise!

Bike rides fine through the gears with no obvious signs of a problem with the clutch. (shifts smooth too) with no other signs of problems.

What could this possibly be? Is this normal?

Thanks
 

Blkoutbusa

Registered
It is not a slipper, it is a torque limiter. Either way, it is a POS. Take the clutch apart, take that torque limiter out and either get it welded, or replace it with Brock's . . .
Is the only real "advantage" of the Brock's piece over a welded one the weight savings part?
 

mabupa

Registered
It is not a slipper, it is a torque limiter. Either way, it is a POS. Take the clutch apart, take that torque limiter out and either get it welded, or replace it with Brock's . . .
Frank, do you think the addition of this part would help my issue with the false neutral between 5th and 6th on my 2009? It feels like parts are chattering for a split second and then falls into gear. Now, which gear it falls into, is like playing Russian roulette. It might fall in 6th or might fall back down into 5th. It’s annoying as hell and I’ve been trying to remember to make my last shift clutchless or at higher RPMs. These are the only two way I can make it do what is supposed to do. I wanted to take a video and upload it before asking for advice, but my sena camera order is delayed, so can’t take a video right now.
 

c10

Registered
Frank, do you think the addition of this part would help my issue with the false neutral between 5th and 6th on my 2009? It feels like parts are chattering for a split second and then falls into gear. Now, which gear it falls into, is like playing Russian roulette. It might fall in 6th or might fall back down into 5th. It’s annoying as hell and I’ve been trying to remember to make my last shift clutchless or at higher RPMs. These are the only two way I can make it do what is supposed to do. I wanted to take a video and upload it before asking for advice, but my sena camera order is delayed, so can’t take a video right now.
Billy @ Robinson industries ( motorcycle trans / maker of overdrive bird gears ) said this was due to dog count when I asked about it years ago . the Gen 1 had less dogs on the gear for 5 to 6 than the Gen 2 . It gets better with miles , and shift like you mean it .
 

mabupa

Registered
Billy @ Robinson industries ( motorcycle trans / maker of overdrive bird gears ) said this was due to dog count when I asked about it years ago . the Gen 1 had less dogs on the gear for 5 to 6 than the Gen 2 . It gets better with miles , and shift like you mean it .
Thanks for the info Bryan!
 

MattyIce 79

Registered
Make sure your vin bike is not one of the affected clutch pressure plate bolts backing out tech bulletin.
A gasket is cheap , and can be checked on side stand losing no oil . Most likely though it tha back torque limiter or aka slipper style clutch .
Hey C10, is there a certain production year for the recall? Or is it just some specific gen 2’s?
 

plucka

Registered
Frank, do you think the addition of this part would help my issue with the false neutral between 5th and 6th on my 2009? It feels like parts are chattering for a split second and then falls into gear. Now, which gear it falls into, is like playing Russian roulette. It might fall in 6th or might fall back down into 5th. It’s annoying as hell and I’ve been trying to remember to make my last shift clutchless or at higher RPMs. These are the only two way I can make it do what is supposed to do. I wanted to take a video and upload it before asking for advice, but my sena camera order is delayed, so can’t take a video right now.
My 2013 does it too mate sometimes. I hardly use the clutch between 5th and 6th.:D
 

plucka

Registered
Hello .org friends,

My gen 2 is making a noise the doesn’t seem right.

When I’m at a stop proceeding to take off, I begin to let out clutch and feel the clutch engage with a low volume knock ( like a “click”). BUT, if I let it out really smooth with a little more throttle, no knock noise!

Bike rides fine through the gears with no obvious signs of a problem with the clutch. (shifts smooth too) with no other signs of problems.

What could this possibly be? Is this normal?

Thanks
Mine does it too. Its more noticeable the hotter the bike gets.
 

MattyIce 79

Registered
Mine does it too. Its more noticeable the hotter the bike gets.
Hey plucka, do u notice any other problems associated with the noise? Just curious. Mine is a 2012. Looks like you’re rockin’ the limited edition, sweet looking bike
 

Yellow09

Registered
Mine makes a slight noise when taking off from a stop and gets a bit louder when hot-normal for a stock clutch system in these things. I'm not fussed in doing anything with mine-it works fine. I have an up only speed shifter so clutchless shifts are no problem if I want.
 

Similar threads





Latest Bikes

Forum statistics

Threads
171,836
Messages
3,071,143
Members
47,254
Latest member
DClemy
Top