Gauges on 2001 busa





#4
Hey my speedo just quit on me yesterday:angry:. and it's just the speedo everything else works. What gives???
sad.gif
Do I need a new set of gauges or just the speedo guage?? OH where it the best place to shop for parts??
type.gif
 
#6
My guages quit one time..Come to find out I checked all the fuse and the blinker one was bad..Put a new one in and they worked great..I would say check your fuses
 

K Wolf

Donating Member
Registered
#7
Hey my speedo just quit on me yesterday:angry:. and it's just the speedo everything else works. What gives???
sad.gif
Do I need a new set of gauges or just the speedo guage?? OH where it the best place to shop for parts??  
type.gif
Check your Speedo sensor(down near the front sprocket) and its connection. Is the odo working also?

BTW suzuki uses the same speedo sensor on many bikes. I let a friend of mine borrow my busa's to diagnose the same prob. on his Gix1k.
 

TorontoBusa

Donating Member
Registered
#10
(1 BAD 2K @ May 09 2006,05:46) Hey my speedo just quit on me yesterday:angry:. and it's just the speedo everything else works. What gives???
sad.gif
Do I need a new set of gauges or just the speedo guage?? OH where it the best place to shop for parts??   :43:
Mine did the same thing last year, take off the left sife panel and just above the crank, near the resovoir for the cooling there is a plug that accumulates water and corrodes.

Take is apart, clean it with a brass dremel wirebrush, put it back to gether, and rap it up with black tape to make it water tight.

You'll be good as new!!

Let us know if that fiexed the problem, it did for me, and have not touched it since
smile.gif
 

Similar threads




Top