05 busa power cuts off and throws c32 through c35 codes



Candlestick

Registered
So heres the whole thing i got this 05 busa about 3 months ago, ran fine no problems. It from what i can tell has had quite of bit of work done to it, not sure of everything but it has power commander, and set up to run no2 ( ive never ran any) not to say it never has though. Christmas came around and im currently in the army stationed at fort Stewart ga and my home is missouri. The busa is the only vehicle i currently own so i did all the maintenance getting it ready for the ride brakes, fluids, spark plugs, ect. It did fine all the way to missouri. About half way through my leave i went and seen a buddy that got out earlier last year and he lives in an apartment, well i went to show him the bike and a guy came flying into his parking lot and i swerved to miss him and when i did at the time i had a thumb buster "cruise control" on its just a little paddle but anyways i bloped the throttle while swerving and it drifted a little ways and caught traction and i high sided. There was no major damage cause i have frame sliders, just broke the end of my shifter handle, cracked the wind screen and minor scuffs. So for the remainder of my time at home i rode the hell out of it to make sure if it was gonna mess up itd be while i was home not on the way back to ga. Well it did fine, till i got about half way back from Missouri the on the highway it would cut off around 70 to 80 mph like i hit a limiter and once it got back to 65 mph itd come back on with full power and itd do it over and over. Well i got back to ga been riding for about a week and a half not on the highway just around post and it started to do it at lower speeds only when it get to operating temps. Tonight i went out warmed it up and drove to get the codes and it was c32 through c35 the primary injector codes. Ive read almost all the threads on here about this and none of them were complete with end results so i decided to make this one. Things to keep in mind, 1 on the highway coming back if i kept giving increased acceleration it wouldnt cut off till i rolled off (for the most part) 2. I do have minor rust in the top of the tank.(goin to try and drain/derust the tank and clean as good as i can the filter on the pump) 3. Ive checked the tip sensor its fine. Im also gotta figure out how to tell if the kickstand sensor is messing up.
 

SSGT_B

Registered
Make an introduction thread, you will get more help. What’s your MOS? Need more information on bike. You stopped at when I did. Also use the search function for those codes. More people will come along in a while. Did you get the pie?
 

Candlestick

Registered
Make an introduction thread, you will get more help. What’s your MOS? Need more information on bike. You stopped at when I did. Also use the search function for those codes. More people will come along in a while. Did you get the pie?
Sorry i accidentally published and wasnt finished also im a 12B
 

SSGT_B

Registered
Kickstand sensor is easy. Put in gear, keep clutch pulled in and put down the stand. There are more technical ways to do it but it’s a quick test. You could have knocked some rust loose but I have never had that problem therefore more technical people will have to help. Be patient, not everyone on here is in the US or in your time zone. @c10
 

Candlestick

Registered
Kickstand sensor is easy. Put in gear, keep clutch pulled in and put down the stand. There are more technical ways to do it but it’s a quick test. You could have knocked some rust loose but I have never had that problem therefore more technical people will have to help. Be patient, not everyone on here is in the US or in your time zone. @c10
I had actually done that earlier on accident ‍♂ and it shut off so i know its working to at least detect it being down.[/QUOTE]
 

c10

Registered
I'm no GEN one guy but with injector codes I can look to see what Suzuki says to test or do tomorrow . Unless @Kiwi Rider is on , and reference his Gen 1 service manual .
 


Latest Bikes

Forum statistics

Threads
173,383
Messages
3,104,821
Members
47,934
Latest member
Fisdan
Top