02 wiring harness compatible with 07?





Merlot

Donating Member
Registered
#1
Hi to all,
i have tried searching in this forum,i have an 02 busa and i just bought an 07 busa wiring harness.My mechanic says there are some difference and afraid of starting the bike and all.What i found out its the same.Are there any differences and can it be used on an 02?I am using 06 ECU now.please help thanks.:please:
 
#2
Hi to all,
i have tried searching in this forum,i have an 02 busa and i just bought an 07 busa wiring harness.My mechanic says there are some difference and afraid of starting the bike and all.What i found out its the same.Are there any differences and can it be used on an 02?I am using 06 ECU now.please help thanks.:please:
Hi I own an 07 Busa and I recently had some FI light on issues after removing the stock O2 for a wide band O2. My experience with this issue tells me that the 07 model is slightly different elctronically becasue it's complying to Euro 3. I read a lot of posts here regarding pulling of the pins but it didnt work on my biek, I finally solved the issue by soldering a resister to the O2 connector.

You should be fine if you use your existing ECU, i believe the difference lies in the program within. BTW I'm riding the UK version with O2 sensor.
 

Professor

Hayabusa Immortal
Staff member
Administrator
Registered
#3
On the US versions the only changes I'm aware of are lighting. You should be able to change the control modules to 05-07 versions and take advantage of the flash to pass, headlight kill during start, and emergency flashers. I'm not aware if the old ones will plug into the harness and operate with limited function. 02-06 ECUs are the same as well.

Maybe someone will chime in that has delt with the change. I do know it is documented on here to change the earlier versions to new controls. The US models did not come with a o2 sensor until the 08.


323protege, good info on the Euro models! Someone here was wanting to with a US model with a factory O2 to comply with class. I'm not sure if he was able to do it.

And Welcome!
 

Merlot

Donating Member
Registered
#4
Hi I own an 07 Busa and I recently had some FI light on issues after removing the stock O2 for a wide band O2. My experience with this issue tells me that the 07 model is slightly different elctronically becasue it's complying to Euro 3. I read a lot of posts here regarding pulling of the pins but it didnt work on my biek, I finally solved the issue by soldering a resister to the O2 connector.

You should be fine if you use your existing ECU, i believe the difference lies in the program within. BTW I'm riding the UK version with O2 sensor.
Yes mine comes with the O2 sensor too,but i removed it already.Thanks for the info.Now i am waiting for my answer from my mechanic,whether its a 99 to 00 model harness or not?i bought second hand from ebay.:please: be the 1 i paid for
 

Merlot

Donating Member
Registered
#5
On the US versions the only changes I'm aware of are lighting. You should be able to change the control modules to 05-07 versions and take advantage of the flash to pass, headlight kill during start, and emergency flashers. I'm not aware if the old ones will plug into the harness and operate with limited function. 02-06 ECUs are the same as well.

Maybe someone will chime in that has delt with the change. I do know it is documented on here to change the earlier versions to new controls. The US models did not come with a o2 sensor until the 08.


323protege, good info on the Euro models! Someone here was wanting to with a US model with a factory O2 to comply with class. I'm not sure if he was able to do it.

And Welcome!
Thanks for the help and info,i tried searching in the electical section and etc,but not much help.Most are talking about upgrading from the 99 to 00 model to newer models
 

Similar threads




Top