Results 1 to 5 of 5
  1. #1

    Default 2005 Busa fuel problems

    I have a 05 busa that i was running racing gas in then switched back to 93 because I thought my mapping might be off. When you hit 100 it runs like crap like its loading up or missing. Runs fine 0-90 but when you throw the fuel to it it just goes to crap. Any thoughts I'm new to the busa world so any help will be THANKED!!

  2. #2
    DID HE REALLY SAY THAT?
    GoldenChild's Avatar
    Join Date
    May 2004
    Location
    Vancouver Wa
    Posts
    8,549

    Default Re: 2005 Busa fuel problems

    What is it mapped for race gas or pump?

  3. #3

    Default Re: 2005 Busa fuel problems

    Start off by cleaning out the gunk in the fuel filter screen. quick job, won't cost anything. Mine fell on it's face when accelerating, was a bunch of rust and crud clogging the filter screen.

  4. #4
    Seasoned Pilot dmallord's Avatar
    Join Date
    Oct 2008
    Location
    Anaheim, California, United States
    Posts
    362
    Images
    1

    Default Re: 2005 Busa fuel problems

    so, in 1st gear WOT it runs fine till you hit 2nd? i am kidding... kind of.

    describing a problem that occurs at a specific mph is difficult at best to even begin to understand what is going on.

    add some more description. " i cant give it full throttle in any gear, or else it bogs." or perhaps " when im cruising in 3rd gear at 5000 rpm it stutters."

    the more specific you are in describing you condition, the easier it is to give you possible direction.

    good luck!
    2004 hayabusa
    blk/ purple, power commander,
    4 into 1 full yoshimura

  5. #5

    Default Re: 2005 Busa fuel problems

    Ok when you roll into the throttle on take off it seems to be fine until its staying there in the same spot a few sec. It goes to missing and sounds like it's loading up in the air box.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •