Results 1 to 7 of 7
  1. #1
    Rookie
    Join Date
    Jan 2009
    Posts
    229

    Default Speedo Needle "Twitching"

    I'm a little embarrassed about this but I figured if it's going to get fixed I needed to ask.

    After doing the EP-35 install a few weeks ago my speedometer needle "twitches". By that I mean for the first few minutes of the ride I'll be cruising along and the needle will 'tick' or 'jump' a little. It seems after warming up for 10-15 minutes it's fine, and I don't see it at all. It should be noted it doesn't do this for the tech, or any other gauge. Just the speedo.

    I'm hoping it's just the connection to the master assembly, or maybe I didn't pull the rubber piece up over the connections all of the way in the back master assembly and maybe it's getting some interference. Honestly I'm not sure.

    Anyone have any ideas?

  2. #2
    Seasoned Beef


    dadofthree's Avatar
    Join Date
    Sep 2006
    Location
    Barnwell, SC
    Posts
    65,422

    Default Re: Speedo Needle "Twitching"

    Alright, I'll byte, what's an EP-35

  3. #3
    Rookie
    Join Date
    Jan 2009
    Posts
    229

    Default Re: Speedo Needle "Twitching"

    See the DIY LED Flasher Mod

    It's to correct the blinkers hyper-flashing after replacing the stock bubls with LED bulbs.

  4. #4
    Trouble Makers Inc.


    Mr Bogus's Avatar
    Join Date
    Dec 2006
    Posts
    2,085
    Images
    11

    Default Re: Speedo Needle "Twitching"

    you have HIDs?

  5. #5
    Top Gun MikeSomething's Avatar
    Join Date
    Feb 2009
    Location
    New Joisey
    Posts
    1,031
    Images
    1

    Default Re: Speedo Needle "Twitching"

    Quote Originally Posted by dadofthree View Post
    Alright, I'll byte, what's an EP-35
    It's the ID-10-T bolt they fasten onto all muffler bearings...

  6. #6
    Rookie
    Join Date
    Jan 2009
    Posts
    229

    Default Re: Speedo Needle "Twitching"

    Yes I have HIDs, installed them a few weeks prior to the EP-35.

  7. #7
    Trouble Makers Inc.


    Mr Bogus's Avatar
    Join Date
    Dec 2006
    Posts
    2,085
    Images
    11

    Default Re: Speedo Needle "Twitching"

    Quote Originally Posted by Longstone View Post
    Yes I have HIDs, installed them a few weeks prior to the EP-35.
    I would suspect them more myself... My HID's cause this issue on mine.. Well close as I can tell anyway.. I have been told that changing the VSS will fix ti but I have not tried this..

Similar Threads

  1. Haya v ZX12 (for a "fatty"/"lanky" !) ??
    By XXX-Large in forum New Owners Forum
    Replies: 22
    Last Post: 09-22-2010, 05:36 AM
  2. What do you like better? "classifieds" or "for sale" forum
    By soapywang in forum Random Thoughts
    Replies: 3
    Last Post: 09-16-2008, 10:29 AM
  3. Holding bike up to change "dog bones" "links"...?
    By JaviBUSA08 in forum General Bike Related Topics
    Replies: 60
    Last Post: 01-01-2008, 04:58 PM
  4. Can't the "mods" do a little  "modding"
    By BusaCruise in forum Random Thoughts
    Replies: 36
    Last Post: 08-10-2006, 06:21 PM
  5. Called "Nudity" "Porn"
    By alexandraalexis in forum Random Thoughts
    Replies: 31
    Last Post: 01-25-2003, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •